Skocz do zawartości


Netteria.NET

Użytkownik od 10 Jan 2018
Offline Ostatnio aktywny May 14 2019 08:36 PM
-----

Moje tematy

Problem z nawigacją offsetową w presta 1.7

14 May 2019 - 01:50 PM

Mam problem w filtrze gdy w grupie dostępność wybiorę "na magazynie", "niedostępne" to znikają mi wszystkie inne grupy (kategoria, marka, itd). Poza tym filtr działa ok. Co może być przyczyną? Walczę z tym z małymi przerwami już trzeci tydzień. Niby wygląda wszystko w kodzie ok a jednak. Oczywiście odbudowywałem index'y i atrybuty. Ponieważ spadkowy ten sklep to trochę tam bałagan który ciężko ogarnąć i nie mogę nawet dać wyższej wersji PHP niż 5.6 i włączyć debug (nawet jak wyłączę moduły spoza wbudowanych w prestę) Może ktoś podpowie co tam może być nie w porządku. Strasznie mnie to frustruje i właściwie grzecznościowo problem rozwiązuje, zarobić na tym nie zarobię ale chciałbym go rozwiązać.


Paginacja presta 1.7 linki

02 February 2019 - 11:54 AM

Witam
 
Chcę zmienić w paginacji linki z ?page=2 na /2/ i tak dalej. W pliku pagination.tpl zrobiłem sobie w prosty sposób 
{if $page.page===1}
                               href="{$page.url|replace:'/?page=1':'/'}"
                            {else}
                                href="{$page.url|replace:'?page=':''}/"
                            {/if}
 
 
nie wiem jednak jak zrobić aby te linki działału bo oczywiście teraz dostaję 404. Kombinowałem w .htaccess ale  nie to. Pewnie to w kontrolerze trzeba zmienić i wrzucić do overwrite ale nic jakoś na ten temat nie mogę znaleźć
Może ktoś coś podpowie. Będę naprawdę wdzięczny.

Presta 1.6.1.23 - nie działa koszyk

06 December 2018 - 02:31 PM

Witam

 

Mam problem z koszykiem na preście 1.6.1.23. Produkty dodają się do koszyka. Widzę ich ilość przy ikonce. Natomiast po najechaniu nie rozwija się koszyk a co gorsze po kliknięciu nie ładuje zawartości koszyka i całej reszty niezbędnej do zakupu. Próbowałem i na one page checkaut i na krok po kroku. Nie generuje żadnych błędów js. Przynajmniej nic w konsoli nie wyskakuje. W trybie dev nie widzę nic podejrzanego. Sprawdziłem templatkę i jest ok a i na domyślnej presty jest ten sam błąd. Oczywiście wyczyściłem pamięć podręczną. Usunąłem też porzucone koszyki. Wyczyściłem niepotrzebne statystyki itd, z bazy.

Może ktoś miał już taki problem i podpowie w czym może być problem.

 

pozdrawiam

Sławek


Presta 1.7.4.2 - Problem z wariantami towaru na głównej karcie produktu

07 August 2018 - 03:53 PM

Witam

Po aktualizacji do najnowszej wersji mam problem z wyborem wariantu towaru. Wybieram z listy ale za chwilę i tak mi wraca na ten domyślny i oczywiście cena się nie zmienia (są różne) no i klient też nie może sobie tego wariantu wybrać.

Coś nie tak jest z JS

Pusty ciąg znaków przekazany do getElementById(). core.js:632:15
Nie mogę jednak tego jakoś rozkminić

Może ktoś już z tym walczył i podpowie co i jak.
W poprzedniej wersji oczywiście śmigało jak trzeba

Sławek
 

 


Problem z kontrolerem i nowym widokiem strony

04 June 2018 - 07:15 PM

Witam

 

Nie wiem czy to upał, czy brak doświadczenia czy po prostu jestem zbyt głupi:)

Tworzę moduł i 

class KonfiguratorStepModuleFrontController extends ModuleFrontController {
    public $ssl = true;
    public function __construct() {
        parent::__construct();
        $this->context = Context::getContext();
    }

    public function initContent() {
      parent::initContent();
      $this->context->smarty->assign(array());
      $this->setTemplate('module:konfigurator/views/templates/hook/step.tpl');
    }

}

ale zamiast widoku z step.tpl w prawej kolumnie w całym sklepie pojawia mi się tylko strona z zawartością tego .tpl Czyli w moim wypadku sam napis "Strona".

Może jakaś dobra dusza podpowie co robię źle. W necie widzę podobne rozwiązania i wszystko ok. A u mnie taki zonk:(

 

pozdrawiam i dzięki za wszelką pomoc

Sławek